[GI] New BETA download client/browser

Discussion in 'General Archive' started by ]Coldheart[, Aug 7, 2020.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. The new version of the BETA download got up and running okay yesterday.
    This morning, although it took a bit to load the client screen, it was there but very, very slow.
    Trying to sell a single resource type, from mouse button press until the selling was done took 7-8 seconds.
    A portal jump was taking over a full minute and still had not completed. So I quit out of the new download browser.

    Then I went to the Opera browser and logged in.
    Backpage looked okay.
    Changing to the Hangar was the same as a couple of days ago; as was several other tab changes on the backpage.
    However, the client screen is still in a state of trying to load. After about 5 minutes the client had not completed the connection.
    Around the 7 minute mark it did establish a connection.
    . . . and it showed that the jump started from the BETA version did in fact complete and showed in the Opera browser.
    Subsequent portal jumps were completed in a second or two.
    I did see that the resources (Promerium and Seprom) assigned when the download browser was up disappeared from the ship once I switched to the Opera browser.

    { UpDate } After a couple of hours everything seems to be running much smoother than before. Could have been anything between the server(s) and my PC.

    Is there any word on when the forums access will be available in English via the new download version? I get what appears to be the German language text that I guess is the notice to use the forums one must be logged in. With the other browser(s) if logged into the game, once I accessed the forums, it was a auto-login.

    Update as of August 11:
    Although the resource had appeared to be cleared up, today it was back.
    The resource value seems to stay for the most part, but using a portal to change maps will at least remove the resources'
    effect from the ship.
    Swapping ships resets the resource assigned value to zero.
    Resources in storage on the ship seems to be there and stable.

    In addition, a jump via a portal starts a logout timer automatically. If this occurs on accounts with premium, watch closely or you will need to re-log to continue.

    The download browser still does not allow for FORUMS access. Attempts call up whatever browser you had available prior to the beta test, attempts to access forums, but receive a (German language?) message that you need to login in. Guessing they want this to be a separate access....

    Update as of August 14:
    Resources still disappear, but now it also has the intermittent ability to lose resources when just changing between config 1 and config 2.

    Confirmation also of losing both config set ups when just changing ships while on base.
    Note: If ship A has been used doing quests, picking up bonus boxes, etc; then I changed to ship B, it is ship B that has lost the configurations; I re-installed the equipment on ship B, changed back to ship A and ship A appears to be unaffected (at least for now)

    question: is there going to be the same connection to the forums from the BETA download as there is from a regular browser?
    This having to log out from the BETA then re-log from the regular browser makes forum use as bad as the overhead to have the other social media connections for the game.


    Update as of August 15:
    Resource transfer from skylab to ship has an intermittent issue. On August 14th, approx. NOON (LST), initiated a transfer of 2900 rocks (mostly SEPROM and a few PROMERIUM). Transfer was going to take almost 6 hours. That was as per usual, I logged off. Today, about 8:30AM (LST) - logged on and no transfer had been done as well as no transfer in progress.

    Started a small transfer of 5 units each of SEPROM and PROMERIUM. Now, this transfer did complete, however, while I was on the client screen crossing the map, the game started flipping me over to the backpage, and sometimes back to the client screen. This continued until I finally crossed to a DMZ and clicked the backpage manually and accepted the transfer notification.

    Resources assigned to shields or generators still being zeroed out when using the portal.

    NEW! While on the 1-1 map, at the BASE and the after the DMZ tag was showing, tried to change ships. Could not!
    The error message was that I could not change ships as I was not on a base.
    ... apparently this is also happening when using Opera as well.

    Last edited: Aug 15, 2020
  2. Why is there no OS X version of the client?
  3. Dramborleg

    Dramborleg User

    Will there be an Apple Mac version of the client?
  4. Client is still kinda laggy. Not saying that it might be because of my pc (gtx 750, 8gb ram) but on browser I can run the game on 30-60fps on ultra low. But in the client it goes about 10-25fps only, never came over 30fps.

    So it's a PC issue or client issue?
  5. Star*Fire

    Star*Fire User

    I have noticed that you can not use the forum from the download.
    _oversoulpaul_ likes this.
  6. ANZ1996

    ANZ1996 User

  7. I noted that as well, posted a thread. Rouge acknowledged it, and said it was passed on to devs for next version inclusion
    Mod-Rogue likes this.
  8. I have this continuing issue with the download myself. Even after following the suggested fix, it keeps giving me this.

    DarkOrbit.exe- System Error

    The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

    Ive sent support this message and it has not brought results. I need assistance thank you
  9. Besides the technical problems , does anyone have any concerns in regards to the security of the download/server ?

  10. every security concern possible at this point. if the download is flawed, the rest is flawed. i have played since additions to the game began and more times then not there has been issues.
  11. Mod-Rogue

    Mod-Rogue User

    Hello pilot

    for now there is only a Windows version

    I am sorry I can't tell you if there will come a mac version

    but I will pass your request higher up

    Thank you

    Regards Rogue
  12. Mod-Rogue

    Mod-Rogue User

    Hello pilot

    The issue have been forwarded up :)

    Regards Rogue
  13. Mod-Rogue

    Mod-Rogue User

    Hello pilot

    The resource that disappeared are they back , or are you still experience some problems with the beta version ?

    I am not the biggest IT nerd here , with all that installing with the Beta .. So I try my best to help you :)

    Got more concern ?
  14. Mod-Rogue

    Mod-Rogue User

    Hello pilot

    did you try Deep clear uninstall the lately Beta version , and after that download the new one ?

    Regards Rogue
  15. Mod-Rogue

    Mod-Rogue User

    Hello pilot

    did you try Deep clear uninstall the lately Beta version , and after that download the new one ?

    Regards Rogue
  16. I did not notice if any resources were recovered.
    However, using the gate to jump no longer erases whatever resources were present prior to jump - thanks!
    At the moment, the only thing that I find really bothersome at all, is the fact that the download/browser does not have a auto-login feature to the forums using the language set up per the actual game. I use English and the forums show, in what I believe is German [default] that I need to login in; so I have to close out the game and login through the previous browser [my case it's Opera].
    When I tried to keep the game up via the download and use then use Opera, the download browser logged me out.
  17. ANZ1996

    ANZ1996 User

    I downloaded the app when it first came out, however, I just recently formatted and when I came back these couple of days, Found that a whole new version is up, and it keeps giving me an error when attempting an install.
  18. beta client fps about 20, on chrome fps about 50/60. obviously you notice the difference.
  19. Wonderful .
    TY for the reply
  20. souleater1

    souleater1 User

    I've noticed on the new beta that every once in a while, while playing it will freeze-up for a few seconds and the continue on as if nothing happened it did it twice yesterday evening, while in the BL Map.
Thread Status:
Not open for further replies.

Share This Page