[TI] Jackpot Battle!

Discussion in 'General Archive' started by Freaky-do, Dec 8, 2013.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Freaky-do

    Freaky-do User

    I had a problem with joining the jackpot battle today. I was in que just bowt to be ported to fight my opponement when the game froze, i could still move around but noone else was moving, When i closed the page to refresh when i re-joined the game i was in my x-1 map and my jackpot battle icon was gone! Anyone else had the same problem?........ Server GB1
     
  2. well u got lag out from ur game .. and the other opponent poped u.... badluck 4 u :(
     
  3. Freaky-do

    Freaky-do User

    Nope i checked my logg noone popped me, Plus i don't get lagg i never have lagg before or after i joined the jackpot battle....... :p
     
  4. Freaky-do

    Freaky-do User

    tell me about it, Well annoyed! :mad::mad:
     
  5. I make my ship fully upgrade then only I join. Win Win Win ^^
     
    KUILIS and Freaky-do like this.
  6. I had that but i had the jackpot battle symbol however i re-loged my pages because all my drones seemed to of disappeared and then i joined and i was in the jackpot arena.
     
  7. =SERAPH=

    =SERAPH= User

    Hello Freaky-do

    This was actually a common problem during the recent JPA on the EU side. As a result, Support have declared that event void, and will run it again next weekend.
    For details, see the
    Official Announcement.

    ~THREAD CLOSED~
    Answered
     
    Freaky-do likes this.
Thread Status:
Not open for further replies.

Share This Page